The current environment for transformations is fairly outdated (due to compatibility concerns) and needs an update. New transformation environments are now available with an update plan. You may choose to keep your environment in auto update mode or lock your environment to either the current or the future version.

Action needed:
If you want to prevent the new transformations from being updated automatically later this month, you must select the version you wish to use. This update is planned for June 22, 2021.

The following options are available:

  • Leave your setting as is: “1.4.1 - Python 3.8.5 + Pandas 0.25.3 (updates automatically)”. The transformations will update automatically to Python 3.9.5 + Pandas 1.2.4 on June 22, 2021. We recommend choosing this option if you are not relying on Pandas, as it is very likely that your transformations will work without any changes.
  • Lock your transformation environment to the current version by selecting “0.3.3 - Python 3.8.5 + Pandas 0.25.3 (locked)”. The update on June 22 will not affect the transformation.
  • Lock your transformation to the latest future version: “Python 3.9.5 + Pandas 1.2.4 (locked)”. The update on June 22 will not affect the transformation.
  • If you do not want to jump versions, you can choose to lock your transformation to an intermediate version: “Python 3.8.10 + Pandas 1.1.5 (locked)”. The update on June 22 will not affect the transformation.

The Sandbox and Workspace environments will keep running the current version until the switch date on June 22, 2021, at which point they will switch to the latest version (we're jumping the intermediate Python 3.8.10 + Pandas 1.1.5). If you want to continue to use the current (outdated) version of Pandas in the Sandbox/Workspace after this date, you'll have to install it manually.

In the future, we will also be offering at least two versions of the Python transformations: one that updates automatically (the default and current behavior) and one that does not auto-update. That way you can always choose whether your transformation environment is auto-updating or not.